Go Back   Ducati Forum > Ducati Panigale Forum > Ducati 1299

Ducati 1299 Ducati 1299 Forum - Ducati 1299 Panigale Superbike Motorcycle Forum


Thanks Tree1Thanks
  • 1 Post By Mick1976
Reply
 
LinkBack Thread Tools Display Modes
Old Aug 16th 2019, 04:13 AM   #1
Senior Member
 
Joined: Oct 2017
From: Rhode Island

Posts: 131
Thanks: 25

I Ride: 2015 1299
Engine light on and no quick shift available

I've search forums and seems like I need to start with cleaning and Appling dielectric grease to the connectors and cleaning pins.. What connectors do I remove?
I'm not sure exactly what to take apart in this picture? That's guys!!



Last edited by tifosi1299; Aug 16th 2019 at 04:17 AM.
tifosi1299 is offline  
 
Old Aug 16th 2019, 05:23 AM   #2
Senior Member
 
Joined: Jul 2016
From: Nor Cal

Posts: 920
Thanks: 251

Double check the connection on the main connector (1299) has a 3 pin connector. Just un plug it and try plugging it back in if that doesn't fix it then your your shift sensor (that little black box) on top of the shift rod that your finger is pointing at took a crap its common on these things. Best to shit can it and install a Translogic it will work 10 times better then the oem one.
Mick1976 is offline  
Old Aug 16th 2019, 05:37 AM   #3
Senior Member
 
Joined: Oct 2017
From: Rhode Island

Posts: 131
Thanks: 25

I Ride: 2015 1299
cancel saw diagram..Thanks!!

Last edited by tifosi1299; Aug 16th 2019 at 06:21 AM.
tifosi1299 is offline  
Old Aug 19th 2019, 04:36 AM   #4
Senior Member
 
Joined: Oct 2017
From: Rhode Island

Posts: 131
Thanks: 25

I Ride: 2015 1299
TLS-DCS-J3-PAN-ASY

mick I just ordered this kit. I cleaned the 3 pin connector and put dielectric grease, but I'm still getting the engine light and no Qs when light is on. Is there anything I need to know when I install this kit or is it just plug and play?

thanks for the help!!!
tifosi1299 is offline  
Old Aug 19th 2019, 07:10 AM   #5
Senior Member
 
Joined: Jul 2016
From: Nor Cal

Posts: 920
Thanks: 251

Hey man awesome yeah the TL unit is plug n play so if the engine light still coming on then something else is causing the error. Maybe check the shift selector sensor plug that's the other connector right next to your 3 pin connector. If the light is still stuck on and no shifting then I would lean towards the gear selector sensor is bad I have seen it but its pretty rare.


Originally Posted by tifosi1299 View Post
TLS-DCS-J3-PAN-ASY

mick I just ordered this kit. I cleaned the 3 pin connector and put dielectric grease, but I'm still getting the engine light and no Qs when light is on. Is there anything I need to know when I install this kit or is it just plug and play?

thanks for the help!!!
Thanks from tifosi1299
Mick1976 is offline  
Old Aug 20th 2019, 04:53 AM   #6
Senior Member
 
Joined: Oct 2017
From: Rhode Island

Posts: 131
Thanks: 25

I Ride: 2015 1299
Originally Posted by Mick1976 View Post
Hey man awesome yeah the TL unit is plug n play so if the engine light still coming on then something else is causing the error. Maybe check the shift selector sensor plug that's the other connector right next to your 3 pin connector. If the light is still stuck on and no shifting then I would lean towards the gear selector sensor is bad I have seen it but its pretty rare.
Can't find anyone in Usa that has this in stock!!! Omg I ordered it and the company called me and said their inventory was off
tifosi1299 is offline  
Old Aug 20th 2019, 06:10 AM   #7
Senior Member
 
Joined: Jul 2016
From: Nor Cal

Posts: 920
Thanks: 251

They are popular and sell out sometimes. Last one I got was from Moto Mummy give them a shot possible they might have them in stock.


Originally Posted by tifosi1299 View Post
Can't find anyone in Usa that has this in stock!!! Omg I ordered it and the company called me and said their inventory was off
Mick1976 is offline  
Old Aug 20th 2019, 06:32 AM   #8
Senior Member
 
Joined: Oct 2017
From: Rhode Island

Posts: 131
Thanks: 25

I Ride: 2015 1299
Originally Posted by Mick1976 View Post
They are popular and sell out sometimes. Last one I got was from Moto Mummy give them a shot possible they might have them in stock.
that's where I ordered it from and the didn't actually have it in stock
tifosi1299 is offline  
Old Aug 20th 2019, 07:54 AM   #9
Senior Member
 
Joined: Jul 2016
From: Nor Cal

Posts: 920
Thanks: 251

Took me about two weeks to get my last one from them so if you didn't go through with the order just order it directly from Translogic USA.

https://www.translogicusa.com/quicks...php?page=order


Originally Posted by tifosi1299 View Post
that's where I ordered it from and the didn't actually have it in stock
Mick1976 is offline  
Reply

  Ducati Forum > Ducati Panigale Forum > Ducati 1299

Tags
engine, light, quick, shift



Thread Tools
Display Modes


Similar Discussions
Thread Thread Starter Forum Replies Last Post
2015 Ducati 1299 Panigale CAN LINE Internal Sensor Check Engine Light Error ABS Light ducrider Ducati 1299 13 Apr 19th 2019 07:08 PM
Check Engine Light and engine keeps shutting off JeffD Ducati 899 20 Oct 23rd 2014 06:05 AM
For Sale: Shift-Tech Carbon Integrated Tail Light (LIGHT SMOKE) Miami Tricolore Classifieds 6 Jan 17th 2014 07:05 PM
Ducati Quick Shift Marcboumboum Mechanical and Technical 13 Jul 26th 2013 09:51 AM
Engine Warning and Amber engine Light ScrapperX Mechanical and Technical 3 Apr 3rd 2013 02:31 PM


Facebook Twitter Google+ RSS Feed