Go Back   Ducati Forum > Ducati Forum > Ducati Superbikes

Ducati Superbikes Ducati Superbikes Forum


Reply
 
LinkBack Thread Tools Display Modes
Old Dec 22nd 2018, 01:50 PM   #1
Junior Member
 
Joined: Dec 2018
From: Baltimore

Posts: 3
Thanks: 0

Ducati 748 no spark no pump prime

Good day to you all.
Just picked up a 748s in salvage yard, just 3k miles , everything there except the tank and tail.
Both a new ignition switch and the tank just came in today.
Now for the problems:
1. The bike cranks but no spark on both spark plugs
2. The fuel pump doesnít prime when turn on

I tried troubleshooting it to the best I can but no dice.
The bike cranks and has a work side stand switch, you canít crank the starter when it down
The bike has no power going to the fuel pump, test the fuel pump thru direct 12v and it spins. Test the fuel pump plug , from the one that connect to the plug form the bike to the one inside the pump itself, there is a connection. Test the plug coming out of the bike to the fuel pump and no voltage when you turn it on.
Checked all the fuses in the main box as well as the other 2 in the back near the ECU and they were all good.
When I turn on the bike I hear clicks from the relays at; 2 at the seat area, the ones near the battery and near the front of the fairing.
Like I said definitely no spark coming from both cylinder.

The wirings of the bike looks pristine and has not been altered. Running out of ideas. Could it be the ECU? Any help is appreciated
Rainman73 is offline  
 
Old Dec 24th 2018, 04:35 AM   #2
Member
 
Joined: Nov 2018
From: Belgium

Posts: 56
Thanks: 16

I Ride: V4 S Corse (ordered)
check the low fuel level sensor. A break in the cable may cause this.
realnuts is offline  
Old Dec 24th 2018, 04:37 AM   #3
Member
 
Joined: Nov 2018
From: Belgium

Posts: 56
Thanks: 16

I Ride: V4 S Corse (ordered)
and something stupid: check the kill switch and all its wiring
realnuts is offline  
Old Dec 25th 2018, 12:37 PM   #4
Junior Member
 
Joined: Dec 2018
From: Baltimore

Posts: 3
Thanks: 0

Checked the low level sensor, and the wire from connector to one inside the tank is good. No power coming to wire from the bike even on initial key on.

Kill switch is good since it cranks the bike and if I turn it off the starter wonít crank/ engage so I know it works.
Rainman73 is offline  
Old Dec 27th 2018, 02:46 PM   #5
Junior Member
 
Joined: Dec 2018
From: Baltimore

Posts: 3
Thanks: 0

Update, got the bike to fire up. It wasnít the relays. But the wiring that activate it. The left side relay , when turned on doesnít get a ground signal, terminal 85 or 86. So I put a bridge wire for ground and lol the fuel pump started. So I took off the fuel pump and sprayed some starting fuel and fire it up. Started
So now I have to trace why itís not getting a ground signal. Could be the ECU which is the worst case due to costs.
Rainman73 is offline  
Reply

  Ducati Forum > Ducati Forum > Ducati Superbikes

Tags
748, ducati, prime, pump, spark



Thread Tools
Display Modes


Similar Discussions
Thread Thread Starter Forum Replies Last Post
Intermittent Spark Issue HELP!!! jwolfson Ducati 1199 2 Nov 14th 2018 10:59 AM
Spark exhaust V4. Riki Ducati V4 20 Apr 28th 2018 08:02 PM
1199 Fuel Pump Won't Prime yanmirza2731 Ducati 1199 4 Aug 24th 2017 03:03 PM
NGK Spark Plugs for Ducati moto Motowheels 0 Feb 28th 2017 04:29 PM
Spark plugs goldontop Ducati 1199 4 Dec 4th 2014 12:45 AM


Facebook Twitter Google+ RSS Feed