Go Back   Ducati Forum > Ducati Panigale Forum > Mechanical and Technical

Mechanical and Technical Mechanical and technical topics, help, and discussions


Thanks Tree1Thanks
Reply
 
LinkBack Thread Tools Display Modes
Old Jun 1st 2016, 10:36 AM   #1
Senior Member
 
Joined: Apr 2014
From: New York, NY

Posts: 396
Thanks: 165

I Ride: 2011 Monster 796 & 2013 1199 Base
Changing out the Gear Position Sensor - 1199

Having issues with my gear position sensor. Basically it'll show a "-" on the indicator and the maps will be all weird until the bike heats up and the sensor resumes normal function(why, I have no idea). Anyone know if this is a user serviceable replacement? It looks pretty straight forward i.e. screw in the sensor itself and then plug it into the harness.

I wasn't sure whether there had to be any electronic calibration by the dealer. I believe I read earlier that it was plug and play but I can't seem to find the thread.
0612Devil is offline  
 
Old Jun 13th 2016, 09:08 PM   #2
Junior Member
 
Joined: Oct 2013
From: USA

Posts: 9
Thanks: 0

I Ride: 1199 S
The sensor is located at the top rear engine case under the pipe loop and it is a replaceable item.

I will need to run the DDS software and reset the gear position sensor before the new one will function properly. Your dealer can perform this if you do not have any Ducati compatible diagnostics system.

On my 1199S with 27,000 miles I have already replaced it.
DesmoDuck1199S is offline  
Old Jun 13th 2016, 09:45 PM   #3
Senior Member
 
wilkson's Avatar
 
Joined: Jul 2012
From: australia

Posts: 2,899
Thanks: 2441

From memory when I replaced mine the bike would re learn the gear position through the prompts on the dash . It was a while ago but I know I didn't have to take it to the dealer .
wilkson is offline  
Old Jun 14th 2016, 04:45 AM   #4
Senior Member
 
Joined: Feb 2014
From: Oslo, Norway

Posts: 157
Thanks: 82

I Ride: 2012 1199 Pani S
I replaced mine last weekend at 21'km, easy to change yourself, take off right upper fairing to access the harness plug under the electronics holder and just unscrew the brass sensor, took me around 15mins.

My dealer tried resetting the old one, but it was dead, I replaced the sensor and it took the dealer 3-4 minutes to resync the sensor with the gearbox through the DDS software
Thanks from Gecko
mordor is offline  
Old Jun 14th 2016, 05:19 AM   #5
Senior Member
 
Joined: Jul 2012
From: Boston

Posts: 324
Thanks: 36

How much did your dealer charge you for the reset?
kickarsmann is offline  
Old Jun 14th 2016, 06:28 AM   #6
Senior Member
 
Joined: Feb 2014
From: Oslo, Norway

Posts: 157
Thanks: 82

I Ride: 2012 1199 Pani S
The dealer charged nothing for the reset, bought the sensor from them, and service my bikes there, so I guess I got the good customer discount
mordor is offline  
Old Jun 14th 2016, 07:14 AM   #7
Senior Member
 
Joined: Apr 2014
From: New York, NY

Posts: 396
Thanks: 165

I Ride: 2011 Monster 796 & 2013 1199 Base
Great, thanks guys.

I'll try to replace myself and take it in if I have issues.

Weird thing is, the sensor goes all crazy when I first start riding but after about 15 minutes it starts working perfectly. Probably something to do with heat expansion etc of the parts.
0612Devil is offline  
Old Jun 14th 2016, 01:10 PM   #8
Senior Member
 
Joined: Feb 2014
From: Oslo, Norway

Posts: 157
Thanks: 82

I Ride: 2012 1199 Pani S
Mine died on a long sunday trip, but the bike was fully drivable. The next day when the bike was cold it worked fine for around 10-20 mins and started malfunctioning when the bike got warm. So the opposite of your experience

When warm, it alternated between showing a "-" and just randomly showing a number from 1-6, along with a BBS and Gear sensor warning, and also the DTC deactivated and showed a "-" as well, so it is nice to have gotten it replaced and a normal bike again
mordor is offline  
Old Jun 15th 2016, 10:44 AM   #9
Senior Member
 
Joined: Jul 2015
From: Las Vegas

Posts: 136
Thanks: 30

Mine just started acting up. When I'm going over 100mph and I shift into 6th it will read that I'm in 5th. Bike runs fine just shows 5th. anything under 100pmh and its displays 6th with no issues.
cristhian702 is offline  
Old Jun 25th 2016, 07:40 PM   #10
Senior Member
 
JHTmcrider's Avatar
 
Joined: Jul 2013
From: Denver

Posts: 440
Thanks: 125

I Ride: 2014 1199S
Just did mine today and works like a charm now.

Initially thought it was the QS linkage.
JHTmcrider is offline  
Reply

  Ducati Forum > Ducati Panigale Forum > Mechanical and Technical

Tags
1199, changing, gear, position, sensor



Search tags for this page
Click on a term to search for related topics.
Thread Tools
Display Modes


Similar Discussions
Thread Thread Starter Forum Replies Last Post
1199S Gear Position Sensor & Track Night Scotrmz Mechanical and Technical 8 Jul 21st 2014 01:26 PM
Gear Sensor Error redriot Ducati 1199 25 Dec 21st 2013 02:31 PM
Sensor Posizione Cambio / Gearbox Position Sensor Solida KSB Mechanical and Technical 4 Nov 29th 2013 09:41 PM
Gear sensor 'teach-in'... Pouakai Mechanical and Technical 8 Jun 20th 2013 06:51 PM
Gear sensor Faisal Mechanical and Technical 3 Aug 6th 2012 04:14 AM


Facebook Twitter Google+ RSS Feed