Go Back   Ducati Forum > Ducati Panigale Forum > Mechanical and Technical

Mechanical and Technical Mechanical and technical topics, help, and discussions


Thanks Tree1Thanks
  • 1 Post By TurboLag
Reply
 
LinkBack Thread Tools Display Modes
Old Dec 27th 2017, 10:55 AM   #1
Senior Member
 
mark419ny's Avatar
 
Joined: May 2012
From: South Florida

Posts: 5,143
Thanks: 1879

I Ride: 2012 1199s 2014 HP4 2007 zx6r (track)
help brake light constantly on

Need help my break light is staying on. it cant be from the front as i took off the front lever so something with the rear.

i know that the banjo is connected to that spring on the rear break lever . how do i look for this problem. do i take it off? if so how do you take it off? anybody else have this problem? ive heard of the break light not going on but not going off is new to me.
mark419ny is offline  
 
Old Dec 27th 2017, 11:38 AM   #2
Senior Member
 
TurboLag's Avatar
 
Joined: Apr 2015
From: Norway

Posts: 621
Thanks: 266

I Ride: 2015 1299 Panigale
Could still be the front, as the pin that's pushing the switch and deactivates the brake light is on the lever. Remove the lever, and it will be constant om.
Thanks from mark419ny
TurboLag is offline  
Old Dec 27th 2017, 12:19 PM   #3
Senior Member
 
mark419ny's Avatar
 
Joined: May 2012
From: South Florida

Posts: 5,143
Thanks: 1879

I Ride: 2012 1199s 2014 HP4 2007 zx6r (track)
Originally Posted by TurboLag View Post
Could still be the front, as the pin that's pushing the switch and deactivates the brake light is on the lever. Remove the lever, and it will be constant om.
i will check this thanks
mark419ny is offline  
Old Dec 28th 2017, 01:53 AM   #4
Member
 
Joined: Aug 2017
From: Virginia, USA

Posts: 85
Thanks: 48

Do you have an led taillight with integrated signals? If so, unplug the actual tail light plug, run just the signal wires. I had no issues, dealer installed it when new. Plugged it in after some work, found it causes issues, confirmed by a post. Usually just a dash warning, but itís an idea.


Sent from my iPhone using Tapatalk
NESBA53 is offline  
Old Dec 28th 2017, 09:31 AM   #5
Senior Member
 
mark419ny's Avatar
 
Joined: May 2012
From: South Florida

Posts: 5,143
Thanks: 1879

I Ride: 2012 1199s 2014 HP4 2007 zx6r (track)
Originally Posted by NESBA53 View Post
Do you have an led taillight with integrated signals? If so, unplug the actual tail light plug, run just the signal wires. I had no issues, dealer installed it when new. Plugged it in after some work, found it causes issues, confirmed by a post. Usually just a dash warning, but itís an idea.


Sent from my iPhone using Tapatalk
yes mine is the integrated tail light and yes it worked flawlessly for many years. now all of a sudden its not. it has to be a sensor problem. either rear or front lever. signals work fine.
mark419ny is offline  
Old Dec 30th 2017, 08:54 AM   #6
Member
 
Joined: Aug 2017
From: Virginia, USA

Posts: 85
Thanks: 48

Did you have it unplugged, then reinstalled recently?
NESBA53 is offline  
Reply

  Ducati Forum > Ducati Panigale Forum > Mechanical and Technical

Tags
brake, constantly, light



Thread Tools
Display Modes


Similar Discussions
Thread Thread Starter Forum Replies Last Post
Wiring help for brake light JackAttack Mechanical and Technical 6 Aug 3rd 2017 11:13 AM
Brake light issue Tyler1199 Ducati 1199 3 Mar 15th 2015 05:20 PM
Brake light error BowHunter Racing 3 Jan 29th 2013 11:59 AM
Brake light sensor Godspeed Mechanical and Technical 7 Dec 29th 2012 07:19 AM
Brake lights flickering on constantly gillo Mechanical and Technical 5 Nov 1st 2012 03:33 PM


Facebook Twitter Google+ RSS Feed